problems connecting to AP using WPA-PSK, Linux 2.6.16, ipw2200 card (wext driver)

Jouni Malinen jkmaline
Tue Jul 25 21:25:19 PDT 2006

On Wed, Jul 19, 2006 at 01:24:54PM -0700, Ivan Tarasov wrote:

> I've got persistent problems with using wpa_supplicant to connect to an AP
> with WPA authentication. I did an extensive search on mailing lists and
> Internet in general and didn't find any solution, although I've seen a lot
> of reports of similar problems.
> /etc/wpa_supplicant.conf contents is somewhat like this:
> # the following 3 lines were changed and this configuration was the most
> stable
> eapol_version=1
> ap_scan=2

The debug log was not using ap_scan=2. Could you please send another
debug log with ap_scan=2 and the exact matching configuration file for
that log?

> fast_reauth=2
> network={
>    ssid="somessid"
>    scan_ssid=1

scan_ssid=1 should not be used when ap_scan=2.

>    key_mgmt=WPA-PSK
>    proto=WPA
>    pairwise=TKIP
>    group=TKIP
>    psk="somepassword"
> }

Otherwise the configuration looks fine.

> You can find the wpa_supplicant log here:
> I tried to send it as an attach but my messeges never got through some
> filter on the way to the mailing list.

In addition to setting ap_scan=2, could you please add -t to the command
line in order to add time stamps to the debug log? I would like to see
this from wpa_supplicant 0.5.4.

I've been using wpa_supplicant with Intel ipw2915 (using the same driver
as IPW2200 would use) with quite stable results when using Linux 2.6.16.
2.6.15 had major problems in getting anything to work with Cisco APs,
but with 2.6.16, most of those issues seemed to go away. There is one
issue in the first EAPOL frame being sent out before the interface is
set with carrier(?) enabled. My current assumption is that this is a
driver issue, but I have not yet had chance to debug it in more detail.
I have a workaround for this (sleep two seconds before transmitting the
first EAPOL packet), but this should of course fixed in more proper way.
Anyway, the debug log you sent did not seem to have similar issue.

> You might be interested looking at the following lines more thoroughly:
> lines 840-965: wpa_supplicant started authenticating, but suddenly received
> the 0x8b15 during the 4WAY_HANDSHAKE, which it considered to be the sign of
> a wrong password, thus it got disconnected.
> lines 1142-1261: same as above, but it passed the 4WAY_HANDSHAKE and
> received the 0x8b15 event with zero AP address during the GROUP_HANDSHAKE.
> lines 1855-2035: successful connection, I was able to work for some time and
> everything worked fine until it received the 0x8b15 event with zero AP
> address again.

This sounds somewhat similar to what I saw with Linux 2.6.15.. I would
guess that something is timing out and the AP ends up disconnecting the
client. I did not bother debugging this more since 2.6.16 is working in
my setup. You might ask this question on the ipw2200 driver mailing
lists since this sounds like something that is more related to the
driver than wpa_supplicant.

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list