ioctl[...]: No such device

John - JohnRChamplin
Fri Jul 7 10:10:57 PDT 2006

On (07/07/06 00:38), Pavel Roskin wrote:
> Quoting John - <JohnRChamplin at>:
> > Thanks for the quick answer, Pavel. I agree that the problem's
> > probably just bringing the interface up.
> > ...

> iwconfig without arguments will show all interfaces.

root@~# iwconfig
plip0     no wireless extensions
lo        no wireless extensions
dummy0    no wireless extentions

> Do you have
> the driver
> loaded at all?  Did it find the hardware?  "dmesg" shows kernel messages,
> including those from the driver.

I've got hostap and hostap_pci in /etc/modules.
me@~$ dmesg
ieee80211_crypt: registered algorithm 'NULL'
hostap_pci: 0.4.4-kernel (Jouni Malinen <jkmaline at>)

But NB, there's NO entry "hostap_pci: Registered netdevice ..." of
any sort. So maybe it didn't find the hardware.

> Load the driver are try again.  Try to bring the interface up using ifconfi
> Check the kernel messages.
Nothing is changed by
root@~#modprobe hostap hostap_pci
It remains
root@~$ lsmod
hostap_pci             48912  0
hostap                 99140  1 hostap_pci
ieee80211_crypt         5280  1 hostap

root@~# ifconfig wlan0 up
wlan0: ERROR while getting interface flags: No such device

root@~# ifconfig -a
dummy0    Link encap:Ethernet  HWaddr 26:A3:F5:77:D5:19
lo        Link encap:Local Loopback
plip0     Link encap:Ethernet  HWaddr FC:FC:FC:FC:FC:FC

There are no new messages in /var/log/syslog, messages, or kern.log
after these operations.

> Generally, describe what you are doing.  I have no idea from your message i
> "iwconfig wlan0" stopped working after you tried to bring wlan0 up or after
> loaded the driver or after clean reboot.

Actually, I've tried dozens and dozens of ways of getting wlan0 to
recognize one or another access point, including four or five versions
of /etc/network/interfaces, following one or another of the files in
/usr/share/doc/(various). It would take pages and pages to describe it all.

iwconfig wlan0 didn't *stop* working. Before and after loading
drivers, on clean reboot as well, it is constant:
root@~# iwconfig wlan0
wlan0     No such device.

> When reporting problems with software, mention versions of the software inv
> (hostap, kernel).

me@~$ dpkg -l 'hostap*' pcmciautils wireless-utils
ii  hostap-modules-2.6.15-lapdog  0.4.1-1+2.6.15-lapdog-10.00.C Host AP drive
ii  hostap-source                 0.4.1-1                       Host AP drive
ii  hostap-utils                  0.4.0-1                       Utility progr
iF  hostapd                       0.5.3-1                       user space IE
ii  pcmciautils    014-1          PCMCIA utilities for Linux 2.6
ii  wireless-tools 28-1           Tools for manipulating Linux Wireless Exten

The "iF" regarding hostapd is, I think, because it has consistently
failed to set up with three versions of hostapd: 1%3a0.3.7-2, 0.5.0-1
and 0.5.3-1. (apt -f install fails to get any of them fully installed.)

root@~# uname -a
Linux lapdog 2.6.16-lapdog #1 Sun Jul 2 17:04:48 EDT 2006 i686 GNU/Linux

I get the same (lack of) results with an earlier version 2.6.16
as well as the version of 2.6.15 for which hostap-modules last
built. The .config file for all three kernels reads the same:
root@~# cat /boot/config-2.6.16-lapdog | grep -Ein hostap

> In this case, the hardware version of the card may be useful
> as well.

root@~# pccardctl ident
Socket 1:
  product info: "IBM Corporation", "IBM High Rate Wireless LAN PC Card", "Ver
  manfid: 0x0156, 0x0002
  function: 6 (network)

Incidently, the card shows up only once in dmesg:
pcmcia: registering new device pcmcia1.0

> If the driver detects the card, it should print some information,
> such as the firmware versions.  That would be useful too.

Agreed, but it doesn't.

I hestitate to mention it, but the card works find under Windows XP

Pavel, again let me offer thanks for your help.

JohnRChamplin at
PGP key 1024D/99421A63 2005-01-05
EE51 79E9 F244 D734 A012 1CEC 7813 9FE9 9942 1A63
gpg --keyserver --recv-keys 99421A63
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : 

More information about the Hostap mailing list