wpa_supplicant v0.2.4 and vxworks ARM issue

Zimmermann, Christopher Brian Chris cbzimmermann
Thu Nov 18 18:31:41 PST 2004

I am having a problem with porting wpa_supplicant to VxWorks 5.5 and
Hermes 2, for use with WPA-PSK.  
Everything looks good...associating, passing 4-way handshake for
pairwise key, decrypting group key message 1 of 2...however I am getting
MIC errors in both directions.  Two of these causes my Cisco AP1200 to
boot me with an 802.11 Disassociate.
I ran the tests in sha1.c, all passed.  I also added the Pairwise Key
Derivation from H7 of the 802.11i/D10.0 document from April 2004.  This
test passed too.  
How can I be decrypting properly, yet have MIC errors.  I tried flipping
the TX and RX  MIC keys, just in case.  No luck.
I took our latest Windows driver, same firmware as my ARM platform.
This authenticates with my Cisco AP1200, using the exact same
configuration.  I took the TKIP Key and MIC Keys on Windows and told my
ARM platform that was it's pairwise key information.  I then sent out
the same packet for groupwise key message 2 of 2 that Windows did, and
this generates the same TX MIC as Windows does.       
Any ideas/suggestions would be greatly appreciated.
cbzimmermann at agere.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.shmoo.com/pipermail/hostap/attachments/20041118/bfc63e29/attachment.htm 

More information about the Hostap mailing list