VCC_mismatch: VCC_ignore NOT working!!Help

gaurav dawra openapproject
Sun Jul 25 00:58:58 PDT 2004

Hey Thanx for the reply, I appreciate it. Well first of all i am sorry if i 
gave this impression that i am trying to load hostap on laptop, actually it 
is running on laptop and working great for me. What i am trying to do is to 
load it on a *PC104* module with PCMIA adpater on it.  Well bridge from 
ISA/PCMCIA has been detected and that adapter working fine with orinoco 
drivers but has some issues with hostap_cs driver. well i understand a bit 
more about hostap but still cud not able to solve this issue. I will 
appreciate if you , pavel or any other can able to help with this problem.

Neways here is the problem:
I am trying to load Senao NL2511 CD card which is a prism 2 based card.  
When i start "/etc/init.d/pcmcia start"  it comes with High beep and low 
beep meaning card is not detected:(
[root at localhost hostap-driver-0.2.1]# /etc/init.d/pcmcia restart
Shutting down PCMCIA services: done.
Starting PCMCIA services: cardmgr[2606]: watching 2 sockets

cardctl info:
[root at localhost hostap-driver-0.2.1]# cardctl info
PRODID_3="Version 01.02"

cardctl ident:
[root at localhost hostap-driver-0.2.1]# cardctl ident
Socket 0:
  product info: "INTERSIL", "HFA384x/IEEE", "Version 01.02", ""
  manfid: 0x0156, 0x0002
  function: 6 (network)
Socket 1:
  no product info available

[root at localhost hostap-driver-0.2.1]# dump_cis
Socket 0:
    NULL 0ns, 512b
    SRAM 500ns, 1kb
  vers_1 5.0, "INTERSIL", "HFA384x/IEEE", "Version 01.02", ""
  manfid 0x0156, 0x0002
  funcid network_adapter
  lan_technology wireless
  lan_speed 1 mb/sec
  lan_speed 2 mb/sec
  lan_speed 5 mb/sec
  lan_speed 11 mb/sec
  lan_media 2.4_GHz
  lan_node_id 00 02 6f 00 00 01
  lan_connector Closed connector standard
  config base 0x03e0 mask 0x0001 last_index 0x01
  cftable_entry 0x01 [default]
    Vcc Vnom 3300mV Vmin 3V Vmax 3600mV Iavg 300mA
    Ipeak 300mA Idown 10mA
    io 0x0000-0x003f [lines=6] [16bit]
    irq mask 0xffff [level] [pulse]

Socket 1:
  no CIS present

Linux PCMCIA Card Services 3.2.7
  kernel build: 2.4.20 #2 Tue Jun 21 06:36:59 MDT 2005
  options:  [pci] [cardbus] [apm]
Intel ISA/PCI/CardBus PCIC probe:
  Cirrus PD672x rev 00 ISA-to-PCMCIA at port 0x3e0 ofs 0x00
    host opts [0]: [ring] [65/6/3] [1/15/3]
    host opts [1]: [ring] [65/6/3] [1/15/3]
    ISA irqs (default) = 3,4,5,7,11 polling interval = 1000 ms
==>bridge is detected.
cs: memory probe 0x0d0000-0x0dffff: clean.
hostap_crypt: registered algorithm 'NULL'
hostap_cs: 0.2.1 - 2004-05-06 (Jouni Malinen <jkmaline at>)
hostap_cs: setting Vcc=33 (constant)
hostap_cs: setting Vcc=50 (from config)
Checking CFTABLE_ENTRY 0x01 (default 0x01)
  Vcc mismatch - skipping this entry
hostap_cs: GetNextTuple: No more items
prism2_config() failed

[root at localhost hostap-driver-0.2.1]# lsmod
Module                  Size  Used by    Not tainted
hostap_cs              47668   0  (unused)
hostap                100840   0  [hostap_cs]
ds                      8104   2  [hostap_cs]
i82365                 38016   2
pcmcia_core            44736   0  [hostap_cs ds i82365]
8139too                17064   1
mii                     3444   0  [8139too]
mousedev                5208   0  (unused)
keybdev                 2688   0  (unused)

I am using i82365 and ds module. I also tried to load the card with this 
# Optional configuration parameters for hostap_cs.o
# module "hostap_cs" opts "channel=3 iw_mode=3 essid=test ignore_cis_vcc=1"

But it is still not working, well looking at 'dmesg' suggest that there is a 
clear VCC mismatch but why the vcc_ignore not working. I believe hostap_cs 
should ignore the vcc and load the services. The socket does support, 
"compaq WL110" based on hermes chipset and work with 'orinoco_cs.o '  which 
is a 5.0 V card. But it does not work with hostap_cs with Senao Card. Why is 
VCC ignore not working?

Also i tried to load hostap_cs with Netgear PCMCIA card MA401 which is a 
VCC=5.0 card and it  does not work either. As when i plugin this card , the 
keyboard stops responding and i guess even IDE. So when i exclude all irq's 
in 'more /proc/interrupts'  by 'excluding them in 'config.opts'' still it 
hangs and does not work? Yeah !! it only 'beeps once(HIGH)' when i plugin 
VCC=5.0 V card but keyboard hangs.
Does not mean that hostap_cs is loaded but there is an IRQ issue?

Well i even looked into "hostap_cs.c" to get the idea of what is going on. 
But i am not really into hardware:(. Please suggest what is going on with 
it. If this is an IRQ problem. Then i believe there may be some solution to 
it. I will be thankful for some hints.

Looking forward to quick response.


>From: "Brian Sturgill" <zen_hacker at>
>To: openapproject at, hostap at
>Subject: RE: IRQ'S Bugging me!! Help!!
>Date: Sat, 24 Jul 2004 01:03:41 +0000
>What pcmcia controller does the laptop have and what version of the kernel 
>are you running. If it is a later 2.4 kernel and a newer laptop, it 
>probably should be running the yenta_socket driver for pcmcia.  I have an 
>older laptop that was a real bugger to get the card services working in 
>Linux. I couldn't use the yenta_ socket driver. I had to pass some boot 
>options to the kernel when booting to make mine work but it was older 
>hardware (P200mmx laptop). I noticed your /proc/interrupts was showing the 
>i82365 driver. You may try the yenta_socket driver and see what happens.
>Let me know some more info and I may be able to help you
>>From: "gaurav dawra" <openapproject at>
>>To: vda at
>>CC: hostap at
>>Subject: IRQ'S Bugging me!! Help!!
>>Date: Fri, 23 Jul 2004 23:45:43 +0000
>>:) Thanx Denis , i have seen the fireworks, well these IRQ's are bugging 
>>me now :(. It's still NOT working. well i ran script and after 
>>starting the "pcmcia" services it does not respond back, it does not 
>>collect any errors . It seems like HardDisk is not responding back. So all 
>>i can do at that point is take the power off and plug it back to restart 
>>the machine. Kernel just stops working on me.
>>If you have clue how the IRQ's are assigned by the linux kernel.
>>          CPU0
>>  0:      69250          XT-PIC  timer
>>  1:       2184          XT-PIC  keyboard
>>  2:          0             XT-PIC  cascade
>>  8:          1             XT-PIC  rtc
>>11:       8936          XT-PIC   eth0, i82365
>>12:       6630          XT-PIC  PS/2 Mouse
>>14:       9157          XT-PIC  ide0
>>15:      20834          XT-PIC  ide1
>>NMI:          0
>>ERR:          0
>>I have excluded all these above IRQ's in the 'config.opts" file. But Still 
>>Does not work.
>>Can i assign a static irq's to the hostap_cs driver. By modifying the 
>>"config.opts" file. I don't really know what to do, it is kind of 
>>frustating now!!
>>FYI the bridge loads succesfully and but the card is giving the problem. I 
>>can successfuly load the "orinoco" drivers but not the hostap_cs one ?? 
>>If anyone out there have any clue please suggest.
>>>From: Denis Vlasenko <vda at>
>>>To: "gaurav dawra" <openapproject at>
>>>Subject: Re: IRQ interrupt problem& HOSTAP
>>>Date: Fri, 23 Jul 2004 00:16:49 +0300
>>>On Thursday 22 July 2004 19:16, gaurav dawra wrote:
>>> > Thanx denis.
>>> >
>>> > For loading Hostap i just need to start the cardmgr byu 
>>> > start"
>>> >
>>> > What should i do after this, as the keyboard hangs and i could not 
>>>able to
>>> > do anything.
>>>You should create a shell script:
>>>echo "Going to start PCMCIA"
>>>/etc/init.d/pcmcia start
>>>sleep 2
>>>echo "I will collect some data now. Reboot and examine /tmp contents"
>>>cat /proc/interrupts >/tmp/ints
>>>dmesg >/tmp/dmesg
>>>echo "Ok you may reboot me now."
>>>shutdown -r now
>>>Just run it:
>>># sh
>>>and watch the fireworks :)
>>FREE pop-up blocking with the new MSN Toolbar ? get it now! 
>>HostAP mailing list
>>HostAP at

Is your PC infected? Get a FREE online computer virus scan from McAfee? 

More information about the Hostap mailing list