Problems with latest CVS

Jouni Malinen jkmaline
Sat Nov 29 17:18:44 PST 2003

On Sat, Nov 29, 2003 at 09:52:47PM +0100, Michael Guntsche wrote:

> I seem to have found a fix for this problem but I'm not sure if this is
> the right way to do it.
> I removed 
> from hostap_cs.c. Now I seem to have the same behaviour as with 0.1.2.

Those were already commented out when using Linux 2.6.x and ejecting the
card (either physically or with 'cardctl eject') worked there.. I left
the old code for Linux 2.4.x because it looked like it was required for
some versions. Anyway, I just tested Linux 2.4.20 and 2.4.23 with these
defines commented out and both worked fine. I removed those completely
from the development branch, so ejecting the card while the netdevs are
up should now work both with Linux 2.4 and 2.6 kernels.

> I still get the following messages upon the removal of the card though.
> wifi0: card already removed or not configured during shutdown
> wifi0: Interrupt, but dev not OK
> wifi0: card already removed or not configured during shutdown
> Jouni, what do you think about this?

I think this is OK. PC Card has its interrupt line pulled up and when
the card is removed, an interrupt is generated. Those debug messages
could probably just be removed assuming everything seems to be working.
I used them more when the card ejecting was not as stable as it is now.

Jouni Malinen                                            PGP id EFC895FA

More information about the Hostap mailing list