libxml2-2_.dll missing?

Terry L. Ridder artisticforge at
Fri Apr 10 09:19:57 PDT 2015


I am going to assume you are running some version of windows.
I am going to assume that you have kept this version of windows updated.

The problem is not with get_iplayer it is rather with the Perl installation.
Has Perl been updated lately?

I personally would start by searching the PC for the library it is giving the error message about.
Look at the permission of that library and the enclosing folders.

I had an issue with Perl when Macports installed a Perl version which conflicted with the official apple version. Depending the PATH environmental variable setting the error may or may not show up. 

Sent from my iPad
terry l. ridder ><>

> On Apr 10, 2015, at 7:40, Philip Colmer <philip at> wrote:
> I'm getting errors from Perl about various libxml DLLs missing. I've tried
> uninstalling the entire get_iplayer package and reinstalling it from the
> latest exe but it hasn't fixed it.
> The full error from get_iplayer is:
> Can't load 'C:/Program Files
> (x86)/get_iplayer/lib/auto/XML/LibXML/LibXML.dll' for module XML::LibXML:
> load_file:The specified module could not be found at line 190.
> at XML/ line 156.
> BEGIN failed--compilation aborted at XML/ line 156.
> Compilation failed in require at XML/LibXML/ line 19.
> BEGIN failed--compilation aborted at XML/LibXML/ line 19.
> Compilation failed in require at (eval 67) line 1.
> However, that directory does contain LibXML.dll. Also, libxml2-2_.xml exists
> in C:\Program Files (x86)\get_iplayer.
> Any suggestions on how to resolve this, please? I couldn't find any
> references in the mailing list archives.
> Thanks.
> Philip
> _______________________________________________
> get_iplayer mailing list
> get_iplayer at

More information about the get_iplayer mailing list