get_iplayer stopped working in MythTV 0.24

JCA 1.41421 at
Mon Jun 25 12:34:49 EDT 2012

On Mon, Jun 25, 2012 at 10:23 AM, dinkypumpkin <dinkypumpkin at> wrote:
> On 25/06/2012 16:56, JCA wrote:
>> Thanks for your very useful reply. Unfortunately, things are still not
>> working. Here is what I am getting when using the patched version
>> get_iplayer:
> The clue is here:
>> Cache fill:  0.00% (0 bytes)   ERROR: Closing connection:
>> NetStream.Play.StreamNotFound
> For whatever reason, sometimes one or the other of the BBC CDNs (Limelight
> in this case) won't serve a stream.  Unlike when it's recording a live tv
> stream, get_iplayer can't roll over to another CDN when rtmpdump is
> streaming output (to mplayer in this case) and fails due to server error.
> You can try to direct get_iplayer to the single (working) CDN by adding a
> numeral to your mode values, e.g.:
> --modes=flashvhigh2,flashhigh2,flashstd2
> It may take a few attempts, and you may need to flip the 2s to 1s.  The
> numerals are not fixed to a specific CDN since the streams may be presented
> to get_iplayer in a different order at different times.

The --modes line that you posted worked fine for me. Thanks very much.

> PS: please don't top post

My apologies.

More information about the get_iplayer mailing list