not writable?

dinkypumpkin dinkypumpkin at
Tue Jan 3 09:51:35 EST 2012

On 03/01/2012 08:13, Andy Bircumshaw wrote:
> On 2 January 2012, at 17:07, Mex wrote:
>> ...
>> Having an odd problem here, Whatever I do I get this:
>> ERROR: get_iplayer is not writeable - aborting update
>> I have gone through all the get_iplayer files I could find and set the permissions to read and write for everybody but still get the same error.
>> I'm running Fedora 14 (Not going higher until they sort out the horrible new Gnome LOL) on this machine, if that is relevant.
> As I recall this usually happens when you've recently updated&/or run get_iplayer as root, and the cache has dodgy permissions.

Given the error message reported, it should be the former, i.e., the 
get_iplayer script itself isn't writeable because it was 
installed/updated as root.  If your current installation was made via 
package manager (main script usually = /usr/bin/get_iplayer), it would 
probably be best to uninstall with yum and create a fresh installation 
somewhere under your home directory using the tarball from  I'm assuming here that there won't be updated RPMs for 
Fedora 14.  The cache files, downloaded programmes, etc., that Andy 
described won't be affected by uninstalling the get_iplayer package.

More information about the get_iplayer mailing list