not writable?

Andy Bircumshaw andy at
Tue Jan 3 03:13:14 EST 2012

On 2 January 2012, at 17:07, Mex wrote:
> ...
> Having an odd problem here, Whatever I do I get this:
> ERROR: get_iplayer is not writeable - aborting update
> I have gone through all the get_iplayer files I could find and set the permissions to read and write for everybody but still get the same error.
> I'm running Fedora 14 (Not going higher until they sort out the horrible new Gnome LOL) on this machine, if that is relevant.

As I recall this usually happens when you've recently updated &/or run get_iplayer as root, and the cache has dodgy permissions.

Your private files - program index, list of shows that have been downloaded in the past, options and saved searches - are stored in the "~/.get_iplayer" directory. Check permissions of that. If it doesn't exist, check and see if "~root/.get_iplayer" exists - if so, copy (`cp -r`) it to your home and then check permissions (`ls -lR` or `find ~/.get_iplayer -exec chown …`) before running get_iplayer again.


More information about the get_iplayer mailing list