[PATCH 1/5] mfd: mc13xxx: Allow to set callback for mc13xxx

Sascha Hauer s.hauer at pengutronix.de
Sun May 18 23:40:34 PDT 2014


Hi MArc,

On Mon, May 19, 2014 at 09:14:19AM +1000, Marc Reilly wrote:
> Hi,
> 
> I'm a bit slow on this one, so sorry if I'm too late to the party. :)

Don't worry, you're not too late.
> > 
> > +void(*mc13xxx_callback)(struct mc13xxx *mc13xxx);
> 
> 
> Should (can?) this be static?

Yes, it should. fixed.

> > +int mc13xxx_register_callback(void(*callback)(struct mc13xxx *mc13xxx))
> 
> 
> What about mc13xxx_register_init_callback, or something which makes it more 
> apparent when the callback is called.

Indeed that's a better name.

> > diff --git a/drivers/net/fec_imx.h b/drivers/net/fec_imx.h
> > index 0921b52..a77c1dc 100644
> > --- a/drivers/net/fec_imx.h
> > +++ b/drivers/net/fec_imx.h
> > @@ -146,6 +146,7 @@ struct fec_priv {
> >  	void (*phy_init)(struct phy_device *dev);
> >  	struct clk *clk;
> >  	enum fec_type type;
> > +	int phy_reset_gpio;
> 
> 
> Did this sneak in?

Oops. Fixed.

Sascha

-- 
Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |



More information about the barebox mailing list