[RFC/RFT 3/7] ath10k: replace send_head() with tx_sg()

Michal Kazior michal.kazior at tieto.com
Wed Feb 19 08:25:59 EST 2014


On 19 February 2014 13:48, Kalle Valo <kvalo at qca.qualcomm.com> wrote:
> Michal Kazior <michal.kazior at tieto.com> writes:
>
>> PCI is capable of handling scatter-gather lists.
>> This can be used to avoid copying memory.
>>
>> Change the name of the callback while at to
>> reflect its purpose.
>>
>> Signed-off-by: Michal Kazior <michal.kazior at tieto.com>
>
> [...]
>
>> +struct ath10k_hif_sg_item {
>> +     u16 transfer_id;
>> +     void *transfer_context;
>> +     void *vaddr; /* for debugging mostly */
>> +     u32 paddr;
>> +     u16 len;
>> +};
>
> This is the part I don't like. Instead of adding our own structs we
> instead should have everything in skb->cb and pass the skbs around. The
> sad part was that last fall I was working on cleaning up that but never
> found the time to finish it :(

There's simply not enough room to keep it all in ath10k_skb_cb
directly. It doesn't really make any sense to keep it there anyway
because sg_item is used as means to pass a complex function argument
to sg_tx(). The sg_item list is never used again.


Michał



More information about the ath10k mailing list