[RFC/RFT 3/7] ath10k: replace send_head() with tx_sg()

Kalle Valo kvalo at qca.qualcomm.com
Wed Feb 19 07:48:48 EST 2014


Michal Kazior <michal.kazior at tieto.com> writes:

> PCI is capable of handling scatter-gather lists.
> This can be used to avoid copying memory.
>
> Change the name of the callback while at to
> reflect its purpose.
>
> Signed-off-by: Michal Kazior <michal.kazior at tieto.com>

[...]

> +struct ath10k_hif_sg_item {
> +	u16 transfer_id;
> +	void *transfer_context;
> +	void *vaddr; /* for debugging mostly */
> +	u32 paddr;
> +	u16 len;
> +};

This is the part I don't like. Instead of adding our own structs we
instead should have everything in skb->cb and pass the skbs around. The
sad part was that last fall I was working on cleaning up that but never
found the time to finish it :(

-- 
Kalle Valo



More information about the ath10k mailing list