[OpenWrt-Devel] QCA9994 outdoor 13km link

support at maxnet.al support at maxnet.al
Fri Sep 20 16:04:57 EDT 2019

Hi Vincent,

I have tried short distance with ddwrt and i get 1733/1733 datarates and about 1Gbps real traffic using iperf. Ubiquiti and MikroTik have 80MHz outdoor radios and they work good. I don't want to use 160MHz which is very wide and there are lot of 20MHz channels within that will create interferences. Actually i want to benefit from VHT-NSS4 so at 80MHz channel i will get 1560Mbps. Ben Greear also thinks that is something wrong with ACK timing.From: Vincent Wiemann <vincent.wiemann at ironai.com>
Sent: Friday, 20 September 2019, 21:56
To: support at maxnet.al; openwrt-devel at lists.openwrt.org
Subject: Re: [OpenWrt-Devel] QCA9994 outdoor 13km link

Hi Klevis,

have you tried it with a short distance?
If you did you should better ask Ben Greear directly.

By the way ath10k gen 2 chipsets don't work very well with long distance links without a
special feature which implementation is only available to companies like Ubiquiti and very few
people who have an own reverse-engineered implementation.
It works on IPQ401X, QCA9886 and QCA9888 based chips only.

And it is not possible to set a coverage class for gen 2 devices, yet as far as I know due to missing
documentation and implementation (correct me if that information is outdated).
Furthermore a high channel width often results in problems
due to lower receiver sensibility.
We have better experiences with lower channel widths and sometimes get more throughput with that.

Actually I think this does not explain your connection issues as 13 km is not that much.


Vincent Wiemann

On 20.09.19 18:30, support at maxnet.al wrote:
> Hello everyone,
> I am trying to setup a custom made outdoor link with Apu2d2 board devices and QCA9994 cards from compex. After i installed openwrt and ath10k ct driver, kmod ath10k and board-2.bin the device can run a 80MHz channel in WDS AP. The problem is that it won't run as station or station wds. It can scan
> the SSIDs but won't connect them. 
> Any suggestion?
> Thank you!
> Klevis

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20190920/7d52af18/attachment.htm>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list