[PATCH] um: Allow multiple symbol definitions for GCOV builds

Alex Hung alex.hung at amd.com
Thu Jul 23 17:44:24 PDT 2026



On 7/22/26 10:14, Johannes Berg wrote:
> On Wed, 2026-07-22 at 10:09 -0600, Alex Hung wrote:
>>
>> On 7/22/26 08:02, Johannes Berg wrote:
>>> Hi,
>>>
>>> On Tue, 2026-07-21 at 16:23 -0600, Alex Hung wrote:
>>>>>
>>>>> I cannot see how that would possibly result in correct behaviour (beyond
>>>>> being able to link)??
>>>
>>>> Good point. --allow-multiple-definition silences the linker error, but
>>>> picking kernel or libgcov's mangle_path() will break the other at runtime.
>>>>
>>>> I saw your previous patch
>>>> (https://lkml.iu.edu/hypermail/linux/kernel/2103.1/06604.html) to rename
>>>> mangle_path() to seq_mangle_path(). How about reviving it to avoid name
>>>> conflicts instead?
>>>
>>> Honestly, I completely forgot about that. Looks like I ran into the
>>> typical "nobody wants to merge it" problem ...
>>>
>>> johannes
>>
>> Is there any concerns or blockers to merge them?
> 
> I don't _think_ so, I guess it ended up mostly procedural, since it was
> across different maintainers etc., and I lost interest because we
> stopped trying to use gcov.
> 
>> I sure want to revive them.
> 
> Sure, sounds reasonable, feel free, of course!
> 
>> The series may also have a solution for the other patch I sent
>> (https://lore.kernel.org/linux-um/eea36454-cbbe-4690-980d-b4ec9423f3a0@amd.com/T/#u).
> 
> That one we should just apply for ARCH=um, seems reasonable to me.
> 
>> I will test the series and report here later.
>>
> 
> Thanks. Please just resend whatever you think should be included, maybe
> first all the UML stuff separately.

Hi Johannes,

I think the two patches are relevant today

   um: fix CONFIG_GCOV for built-in code
   seq_file: rename mangle_path to seq_mangle_path

I will update the patch date and add my SoB, and then send them to 
mailing list, if that's okay.

> 
> johannes




More information about the linux-um mailing list