5Ghz WiFi blocked by vc4.ko on kernel 5.10.12 on RPi4B 8GB

Ryutaroh Matsumoto ryutaroh at ict.e.titech.ac.jp
Thu Feb 11 22:07:38 EST 2021

Hi Dave, thank you for pointing insallation precedure of Raspberry Pi OS 5.10.
I did the following, and at every step both 2.4GHz and 5GHz worked fine.
I also found two minor bugs in Rapsberry Pi OS.
In short, reported unavailability of WiFi seems to exist only in
the plain upstream kernel...

1. I installed 2020-08-20-raspios-buster-arm64.zip. I found a minor bug:
I chose Country "Japan" and checked "Use English Language" and UNCHECKED "Use
English Keyboard". Then keyboard layout was English! I fixed it by
dpkg-reconfigure keyboard-configuration. The setting of keyboard-configuration
was Enslish, and I changed it to Japanese.
WiFi worked fine at every frequency.

2. I upgraded kernel to 5.10 by
2-1. apt-get update; apt-get --purge --autoremove dist-upgrade
WiFi worked fine at every frequency.

3. I upgraded Rapberry Pi OS to Bullseye by
3-1. Adding deb http://deb.debian.org/debian bullseye main contrib non-free
3-2. apt-get --with-new-pkgs --autoremove --purge upgrade
3-3. apt-get --autoremove purge libgcc-8-dev gcc-8-base
3-4. apt-get --autoremove --purge dist-upgrade
3-5. apt-get --autoremove purge libpython2-stdlib python2 python2-minimal
WiFi worked fine at every frequency.

I experienced the problem with the Gnome desktop, so I installed Gnome on
Rapsberry Pi OS and saw what happened.

4-1. apt-get purge pi-package pi-package-data pi-package-session
4-2. apt-get --purge --autoremove install task-gnome-desktop gdm3
Network Manager doesn't work well with dhcpcd5, so
4-3. apt-get purge dhcpcd5

Every freqnency of wlan in my house worked fine with Gnome Network Manager...
gdm3 and the gnome sesssion worked completely well!

Ok, the difference could be coming from difference of config.txt. So I edit
config.txt in the following way, which make it similar to the one I saw problems
with WiFi. In particular, the plain upstream kernel has vc4.ko but doesn't have

# Comment it out!

I also added "module_blacklist=v3d" to cmdline.txt.

With that config., WiFi worked well at every frequency...

I attach "dmesg" + "lsmod" + "journalctl -b" as a compressed file
in the above configuration.

Minor bug in Raspberry Pi OS: When I comment out both
The gdm3 display manager fails to start...

Best regards, Ryutaroh
-------------- next part --------------
A non-text attachment was scrubbed...
Name: log-nov3d-2.txt.xz
Type: application/octet-stream
Size: 23892 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/linux-rpi-kernel/attachments/20210212/071ec48e/attachment.obj>

More information about the linux-rpi-kernel mailing list