[RFC] mailbox: Add Broadcom BCM2835 mailbox driver

Craig McGeachie slapdau at yahoo.com.au
Wed Aug 21 02:31:33 EDT 2013

On 08/21/2013 03:30 PM, Stephen Warren wrote:
> Per Documentation/SubmittingPatches, assuming Lubomir's patches are
> already appropriately licensed and signed-off, you're quite free to take
> those patches, modify them as necessary, make a note of what you
> changed, add your sign-off, and repost the result for inclusion upstream.

Thank you very much.  I shall try that, but I will probably go quiet for 
a while.  I'm finding it difficult to get the current upstream kernel to 
boot.  It compiles all right, but I can't get it loaded an booted.  I 
tried the Raspberry Pi foundation bootloader, which has a device tree 
option instead of atag, but that just gave me a panic, for reasons I've 
not explored yet - I may simply need to adjust the values in the device 
tree.  I've tried u-boot, which loads up just fine, but it refuses to 
read the SD card (something about unknown partition table) and almost 
any time I do anything with the USB device tree in terms of transferring 
200+K of data it freezes up (TFTP, USB memory stick). I'm not at an 
impasse yet though.  I have other boards to try, and possibly other work 


More information about the linux-rpi-kernel mailing list