[2/3] 2.6.22-rc2: known regressions v2
torvalds at linux-foundation.org
Thu May 24 15:50:22 EDT 2007
On Thu, 24 May 2007, Ingo Molnar wrote:
> i very much agree that this kmalloc_index() one shouldnt be called a
> "BUG: ", but if you look at the majority of WARN_ON() instances they are
> checks for clear, serious kernel bugs.
I _still_ disagree.
There's a huge difference between "You killed my father, prepare to die",
and "Btw, I didn't like that, but I'll just continue".
And that's the difference between BUG_ON() and WARN_ON().
And dammit, the kernel message should make that CLEAR. It's totally
idiotic to call both "BUG". One is a clear BUG, the other is a "uhhuh,
something unexpected happened, but I know how to continue".
So stop this idiotic "we should call them both the same". If they actually
were the same, they'd both be called BUG_ON().
More information about the linux-pcmcia