Aircard 850 on a Thinkpad Z61m

Peter Stuge stuge-linux-pcmcia at
Wed Jun 20 18:53:36 EDT 2007

On Wed, Jun 20, 2007 at 06:43:36PM -0400, josh at wrote:
> >> cardmgr[7219]: could not adjust resource: IO ports 0xa00-0xaff:
> >> Function not implemented


> > cardmgr is deprecated with 2.6, try using pcmcia-socket-startup
> > instead.
> Interesting. I am running Debian (unstable) pcmciautils version
> 014-3. I ran /lib/udev/pcmcia-socket-startup, and no TTY gets
> assigned to the Aircard. A tty does get assigned after I run
> cardmgr. As I mentioned before I'm running kernel 2.6.18-3.

I'm afraid I can't say whether this is a regression in 2.6.18-3 or
just an error in cardmgr.

Either way, cardmgr can not work with newer kernels.

> When I run cardmgr /dev/modem gets created as a symlink to
> /dev/ttyS0. As I mentioned I tried running minicom /dev/ttyS0 and
> typing AT but did not see the text showup.

The "Function not implemented" errors mean that cardmgr is unable to
do things it wants to do to get the card working because the kernel
no longer supports that way of doing things.

Can you try the latest vanilla kernel?


More information about the linux-pcmcia mailing list