Aircard 850 on a Thinkpad Z61m

josh at josh at
Wed Jun 20 18:43:36 EDT 2007

On Thu, 21 Jun 2007, Peter Stuge wrote:

> On Wed, Jun 20, 2007 at 06:18:09PM -0400, josh at wrote:
>> cardmgr[7219]: could not adjust resource: IO ports 0xa00-0xaff: Function not implemented
>> Any ideas what is causing the input/output error in wvdial on
>> /dev/ttyS0? Is that connected to the errors I see when starting
>> cardmgr?
> Possible. Just replied in private, but here's the important parts for
> reference;
> cardmgr is deprecated with 2.6, try using pcmcia-socket-startup
> instead.

Interesting. I am running Debian (unstable) pcmciautils version 014-3. I
ran /lib/udev/pcmcia-socket-startup, and no TTY gets assigned to the
Aircard. A tty does get assigned after I run cardmgr. As I mentioned
before I'm running kernel 2.6.18-3.

When I run cardmgr /dev/modem gets created as a symlink to /dev/ttyS0.
As I mentioned I tried running minicom /dev/ttyS0 and typing AT but did
not see the text showup.

  - Josh

More information about the linux-pcmcia mailing list