PCMCIA / compact flash / au1x00

Aeschbacher, Fabrice Fabrice.Aeschbacher at siemens.com
Fri Apr 20 08:17:28 EDT 2007

> Try using the PCMCIA PATA driver instead.

This does not seem to work either. In this case, which would be the
device? /dev/hda? or /dev/sda? something else?

> > Neither hotplug nor udev is installed (I only installed 
> > /sbin/pccardctl).
> Then you'll have to run pcmcia-socket-startup manually. This 
> may actually work also with ide-cs. Try this before PCMCIA PATA.

I tried to run pcmcia-socket-startup, without success. It does not
display any message, neither on stdout nor in dmesg. I tried without
parameters, with 0 then with and 0.0 as parameter.

In /proc/bus/pccard, there should be a sub-directory "00", but it is not
Moreover, 'pccardctl status' display the subdevice 0 as 'unbound'
(should be 'bound', I imagine):

  # pccardctl status
  Socket 0:
    3.3V 16-bit PC Card
    Subdevice 0 (function 0) [unbound]

But the kernel recognizes when I plug the CF card in and out (I can see
messages on the console).

Best regards,
Fabrice Aeschbacher

More information about the linux-pcmcia mailing list