How to investigate PCMCIA driver loading (freeze)

Fab G. fabrataz at
Wed Nov 29 17:01:03 EST 2006


I am quite new to this so bear with me.

Here's a short description of my problem:

I installed Xubuntu edgy (kernel 2.6.17) on an old p233 laptop.

I would like to use a PCMCIA (16bit) generic Wifi card but when the
card is inserted in the pcmcia slot, the PC freezes. The last message
I can get (through tail'ing syslog) is
registering new device pcmcia0.0

I've done some reading and I tried to "exclude" a bunch of irqs in
/etc/pcmcia/config.opts without any result

I then tried to change the card driver (orinoco) by creating a
blacklist file in /etc/modprobe.d  - after that the freeze did not
happen anymore. Actually nothing happened (after "registering new
device pcmcia0.0") as if no module was loaded.

I know I have the hostap driver available (I can even modprobe it at
will) but it does not seem to be loaded when the card is plugged in
(and no Wifi interface is created).

Nonetheless I was able to identify the card and it has the same Manf
id=0x0156, 0x0002 as an Intersil or Prism2 based card.

Since with the new pcmcia scheme in kernel 2.6 I can't apparently
force the loading of hostap_cs (using some config file in
/etc/pcmcia), I don't know how to investigate what the kernel is doing
when the card is plugged. I blacklisted the orinoco so it cannot load.

The orinoco_cs source  has the card's reference in the PCMCIA_DEVICE_
in the pcmcia_driver struct and the hostap_cs.c also has the same data
in its struct, shouldn't it be loaded instead of orinoco_cs ?

I am not familiar with that kind of debugging, is there any additional
log available (by changing syslog.conf maybe) or do I need to
recompile the drivers  ?

Any other Cardbus card I've tried is working fine.



More information about the linux-pcmcia mailing list