Cardbus Failure "cs: warning: no high memory space available!"

Mark Fortescue mark at
Tue Dec 5 11:35:00 EST 2006


I have been unable to get the Cardbus/PCMCIA system to work in any shape or
form. I have tried various suggestions from similar looking issues located
using GOOGLE but I have yet to get anything that hints at working or
identifying the issue preventing operation.

The pccarcctl utility allows me to change the power state and eject/insert
the cards however ident/info return no useful or meaningful information for
the two CompactFlash devices I have tried (a Flash Disk [Works fine using
linux-2.2.x on my old laptop {also yenta cardbus}] and a GPS card that
should look like a serial port). Both devices work under WinXP.

I am using a generic Linux- kernel on a Clevo 470K Laptop so the
cardbus bridge is a CB1410.
The kernel log eventually comes up with cs: warning: no high memory space

Please can you tell me:

1) What (if any) patches need to be applied to the kernel and where can I
get them.
2) What (if any) special configuration options do I need to set (build time
and/or kernel command line). My current kernel is mostly not modular.
3) What additional pieces of software do I need (including version numbers
and patches as there appears to be a great deal of incompatibility between
different versions of tools like UDEV).

	Mark Fortescue

More information about the linux-pcmcia mailing list