Modem PC Card on Compaq nx6110: No serial port created

Alex Kavanagh alex at
Sat Apr 8 15:43:44 EDT 2006

At Sat, 08 Apr 2006 17:38:09 +0100,
Alex Kavanagh wrote:
> Hi
> I've just joined the list.  However, scanning through the recent
> archives, I've noticed that I have exactly the same problem as you do.
> Please see below:
> At Sat, 08 Apr 2006 16:51:02 +0200,
> Pascal MALAISE wrote:
> > 
> > I have just tested the pcmcia modem card on my IBM Thinkpad 770 (with
> > Ubuntu Breezy and kernek, like on my Compaq nx6110), and it
> > works. There is the trace from cs and a ttyS is created:
> > 
> > pccard: PCMCIA card inserted into slot 1
> > cs: memory probe 0xa0000000-0xa0ffffff: clean.
> > pcmcia: registering new device pcmcia1.0
> > 1.0: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
> > pccard: card ejected from slot 1
> > 
> > So the problem appears to be with pcmcia modem cards on the Compaq
> > nx6110. Can it be because there is no serial port at all on this laptop?
> > Or is there a specific PCI/ISA bridging?
> Yes, I think it is.  I have a HP DV1448 laptop and my 3G Novatel
> Merlin U630 gets scanned in okay but the serial port fails to arrive.
> We both have TI PCIxx21 Cardbus PCI bridges on our laptops and I'm
> convinced this is the problem.  I tried the same card on the same OS
> (Ubuntu 5.10 - 2.6.12 kernel) on a HP 3000 based laptop and the card
> worked perfectly.  Thus I am convinced it is the PCIxx21 chipset that
> is the culprit.
> I've done the pci=assign-busses, override-bios=1 and neither helped.
> I even upgraded to and that hasn't helped either.
> Any idea what I can try next? There are no error messages either.
> Just setserial indicating that no uart has been found:
> /dev/ttyS0, Line 0, UART: unknown, Port: 0x03f8, IRQ: 20
>         Baud_base: 115200, close_delay: 50, divisor: 0
>         closing_wait: 3000
>         Flags: spd_normal skip_test

Having looked at the code in the file serial_core.c the following
appears in 'uart_add_one_port' which is called (eventually) from

         * Register the port whether it's detected or not.  This allows
         * setserial to be used to alter this ports parameters.
        tty_register_device(drv->tty_driver, port->line, port->dev);

i.e. I think this means that even if the port isn't found the serial
device is still allocated.  So does this mean that even if the pcmcia
subsystem doesn't actually find the UART (due to a bug or not coding
for the PCIxx21 chipset the serial device is still allocated and no
error message is generated?

Any idea where I look next?


More information about the linux-pcmcia mailing list