Modem PC Card on Compaq nx6110: No serial port created

Battle Nick Nick.Battle at
Thu Apr 6 03:43:13 EDT 2006

> No sorry. I have even tried ttyS0 to ttyS3 with minicom. There is
> definitely no ttySx created, and, as far as I can see no trace from
> serial_cs at all.

I have an HP nc6120, which is very similar to the nx6110. I get the same
behaviour by the sound of it: serial_cs is loaded, but no new tty devices
appear, and tools like wvdialconf can't find a modem anywhere.

I posted the note below on a SuSE discussion list, thinking it was more
likely to be a problem with udev or the replacement of the old card services
than a problem with my new laptop or serial_cs itself. Perhaps that's wrong.
There were no responses.

In the end I gave up and switched to using the built-in modem which works
fine. Happy to discuss how to do that, but this is the wrong list :)


I have an old (16 bit) PCMCIA modem card - an Olicom GoCard. This used to
work fine with a 2.6.14 kernel under SuSE 9.2 via the old cardmgr system
using the serial_cs module, so I know the card is OK. But I'm having trouble
getting it to work in SuSE 10.0 with the new udev-driven event system.

When the card is plugged in, the Olicom device details appear under the /sys
filesystem somewhere, and "pccardctl info" will print them out. They all
look correct.

When I use "pcccardctl insert" (or eject then insert), I can see a pcmcia
event go through the udev system and match against all the rules until it
comes to the set in 50-pcmcia_socket (I think that's the name... under
/etc/udev/rules.d anyway). This dispatches hwup, as you might expect, but it
passes a MODALIAS variable of "pcmcia:<gobbldegook>", which hwup attempts to
modprobe literally, which fails. The value of the MODALIAS passed seems to
come from the /sys filesystem, which has a "modalias" file in the device's
details directory.

I assume the end result of the hwup should be to modprobe serial_cs, so I
modified the udev rule to set ENV{MODALIAS} to "serial_cs" as well as
RUN+=hwup, and this does cause the module to be loaded after the pccardctl
insert. But this doesn't result in a usable tty - eg. wvdialconf can't
recognise any ttys as being a modem.

I tried additionally calling pcmcia-socket-startup, but that doesn't help.

I'm not sure where to go with this next. Does anyone have any ideas?

More information about the linux-pcmcia mailing list