Issue with P222 PCMCIA on desktop

Khamar, Kalpit K (Kalpit) kkhamar at
Fri Feb 11 19:32:36 EST 2005

Hi Dave and All,

I tried useing P222 with all different falvoure of Linux operating system (Red Hat9, 10, Fedora core 1, 2, 3) and out of that only Fedora Core 3 works for me to see PCMCIA cards from P222 on operating system. 

I am trying to use Sierra Wireless 575 PCMCIA aircard which is giving problem on desktop. I tried using this card on laptop loaded with redhat 9 and Fedore 2 and on both the time this cards works on laptop. On the laptop it will create serial device /dev/ttyS1 as soon as i slide card in PCMCIA slot. Now this card is 16 bit PCMCIA card and when i use any 16 bit PCMCIA card on desktop with P222, it is not seeing the card as a hot swap, i have to reboot the desktop and during the boot it will identify the card. My problem is that Sierra Wireless 575 PCMCIA 16 bit card creates /dev/eth1 on desktop when i use it with P222 on Fedora core 3. I need to send couple of command to the cards and i am not able to talk to the card. Can you please tell me why it's not creating /dev/ttyS1 or any serial device on Fedora core 3 with P222?

Below is the instructing i am trying to follow.

Add the following to /etc/pcmcia/config under the Modems and other serial devices: 

card "Sierra Wireless AirCard 575 A575 Rev 1" 
manfid 0x0192, 0xa575 
cis "cis/SW_575_SER.dat" 
bind "serial_cs" 

Copy the file SW_575_SER.dat in this archive in /etc/pcmcia/cis/ 
Restart computer. 
Insert the AirCard 575 

Still it won't see the card so i have to reboot again and at that time it will identify card as a network adapter instead of serial device.

Attachment is a file SW_575_SER.dat

Please let me know if you need more informations.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: SW_575_SER.dat
Type: application/octet-stream
Size: 123 bytes
Desc: not available
Url :

More information about the linux-pcmcia mailing list