2.6.* PCMCIA Issue with two network cards.

Craig Bergstrom humbucker00 at hotmail.com
Fri Aug 6 20:33:26 EDT 2004

Hello everyone,

I am writing to report a bug, maybe this will help someone fix this so that 
other people dont run into the same problem.  I have an old Toshiba T2400CS 
Satellite Pro Laptop computer, it's nothing special, with 20 megs of ram and 
a 486 50Mhz/DX2, but it enough to do wireless routing, so I've got two 
network cards that i've been trying to get to work in it's two PCMCIA slots. 
  I was working with the 2.6.7 kernel, and no matter what I did, i would get 
an error when I loaded cardmgr (see the very bottom of the /proc/kmsg 
listing for the exact errors.)  Cardmgr would report that it could not map 
the card memory whenever I tried to have two cards inserted at the same 
time.  However, whenever either card was inserted on it's own, it would 
work.  Regardless of which slot I inserted the individual card into.  (so 
there was definatly no faulty hardware)

In order to fix the problem, I simply compiled and installed the 2.4.22 
kernel and everything worked fine.  I suggest the same for anyone else 
having similar problems with the 2.6.7 kernel.

Anyway, here's the listing of /proc/kmsg.  I hope that this helps someone 
track down the problem so that it can be fixed for future users. (or so that 
I can use the nifty features of the new kernel versions later!)

root at outpost [22:31:58 ~] cat /proc/kmsg
<4>Linux version 2.6.7 (root at mobile) (gcc version 3.2.2
20030222 (Red Hat Linux 3.2.2-5)) #1 Sun Aug 1 00:22:44 EDT 2004
<6>BIOS-provided physical RAM map:
<4> BIOS-88: 0000000000000000 - 000000000009f000 (usable)
<4> BIOS-88: 0000000000100000 - 0000000001430000 (usable)
<5>20MB LOWMEM available.
<4>On node 0 totalpages: 5168
<4>  DMA zone: 4096 pages, LIFO batch:1
<4>  Normal zone: 1072 pages, LIFO batch:1
<4>  HighMem zone: 0 pages, LIFO batch:1
<6>DMI not present.
<4>Built 1 zonelists
<4>Kernel command line: auto BOOT_IMAGE=net ro root=301
<6>Initializing CPU#0
<4>CPU 0 irqstacks, hard=c03a1000 soft=c03a0000
<4>PID hash table entries: 128 (order 7: 1024 bytes)
<6>Using pit for high-res timesource
<4>Console: colour VGA+ 80x25
<6>Memory: 17188k/20672k available (1896k kernel code, 3048k
reserved, 573k data, 204k init, 0k highmem)
<4>Checking if this processor honours the WP bit even in
supervisor mode... Ok.
<4>Calibrating delay loop... 8.19 BogoMIPS
<6>Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
<4>Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
<4>Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
<7>CPU:     After generic identify, caps: 00000003 00000000
00000000 00000000
<7>CPU:     After vendor identify, caps: 00000003 00000000
00000000 00000000
<7>CPU:     After all inits, caps: 00000003 00000000
00000000 00000000
<4>CPU: Intel 486 DX/2 stepping 05
<6>Checking 'hlt' instruction... OK.
<6>NET: Registered protocol family 16
<6>EISA bus registered
<6>mtrr: v2.0 (20020519)
<6>Toshiba System Managment Mode driver v1.11 26/9/2001
<6>Linux Kernel Card Services
<6>  options:  [pm]
<6>apm: BIOS version 1.1 Flags 0x02 (Driver version 1.16ac)
<6>audit: initializing netlink socket (disabled)
<3>audit(632096989.545:0): initialized
<6>Real Time Clock Driver v1.12
<6>Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ
sharing disabled
<4>Using anticipatory io scheduler
<6>Floppy drive(s): fd0 is 1.44M
<6>FDC 0 is an 8272A
<6>nbd: registered device at major 43
<7>orinoco.c 0.13e (David Gibson
<hermes at gibson.dropbear.id.au> and others)
<7>orinoco_cs.c 0.13e (David Gibson
<hermes at gibson.dropbear.id.au> and others)
<6>Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
<6>ide: Assuming 50MHz system bus speed for PIO modes;
override with idebus=xx
<4>hda: TOSHIBA MK1824FCV, ATA DISK drive
<4>ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
<4>hda: max request size: 128KiB
<6>hda: 687980 sectors (352 MB) w/128KiB Cache, CHS=682/16/63
<6> hda: hda1
<4>ide-floppy driver 0.99.newide
<6>Intel ISA PCIC probe:
<6>  Intel i82365sl B step ISA-to-PCMCIA at port 0x3e0 ofs
0x00, 2 sockets
<6>    host opts [0]: none
<6>    host opts [1]: none
<6>    ISA irqs (scanned) = 3,4,5,7,9,10,12,15 status change
on irq 15
<6>Databook TCIC-2 PCMCIA probe: not found.
<6>mice: PS/2 mouse device common for all mice
<6>serio: i8042 AUX port at 0x60,0x64 irq 12
<6>serio: i8042 KBD port at 0x60,0x64 irq 1
<6>oprofile: using timer interrupt.
<6>NET: Registered protocol family 2
<6>IP: routing cache hash table of 512 buckets, 4Kbytes
<6>TCP: Hash tables configured (established 1024 bind 2048)
<6>IPv4 over IPv4 tunneling driver
<6>GRE over IPv4 tunneling driver
<4>ip_conntrack version 2.1 (161 buckets, 1288 max) - 296
bytes per conntrack
<4>ip_tables: (C) 2000-2002 Netfilter core team
<6>ipt_recent v0.3.1: Stephen Frost <sfrost at snowman.net>.
<4>arp_tables: (C) 2002 David S. Miller
<6>NET: Registered protocol family 1
<6>NET: Registered protocol family 17
<5>Bridge firewalling registered
<6>NET: Registered protocol family 4
<6>NET: Registered protocol family 5
<6>802.1Q VLAN Support v1.8 Ben Greear <greearb at candelatech.com>
<6>All bugs added by David S. Miller <davem at redhat.com>
<4>VFS: Mounted root (ext2 filesystem) readonly.
<6>Freeing unused kernel memory: 204k freed
<4>EXT2-fs warning: mounting unchecked fs, running e2fsck is
<6>cs: IO port probe 0x0300-0x031f: clean.
<6>cs: IO port probe 0x0140-0x017f: clean.
<6>cs: memory probe 0x0d0000-0x0dffff: clean.
<5>pcnet_cs: RequestWindow: Resource in use
<6>eth0: NE2000 Compatible: io 0x300, irq 4, hw_addr
<6>input: AT Translated Set 2 keyboard on isa0060/serio0
<5>cs: unable to map card memory!
<5>cs: unable to map card memory!
cardmgr[304]: unsupported card in socket 0
cardmgr[304]:  no product info available

Thanks y'all!

Is your PC infected? Get a FREE online computer virus scan from McAfee® 
Security. http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963

More information about the linux-pcmcia mailing list