[SUMMARY] today's pcmcia patches
rmk at arm.linux.org.uk
Wed Jun 11 12:47:53 BST 2003
On Thu, Jun 05, 2003 at 11:10:48PM +0200, Dominik Brodowski wrote:
> move_socket_info_t: move cs.c's socket_info_t to include/pcmcia/ss.h and
> rename it to struct pcmcia_socket.
> move_get_socket_info_by_nr: move the number resolving part of the bus socket
> list from ds.c to cs.c.
> remove_socket_table: the socket_table in cs.c is replaced by a dynamic list
> which is protected by a rw_sem.
> true_driver_module_locking: in addition to preserving userspace (e.g. cardmgr)
> reference counting, try_module_get and module_put calls are added so that no
> pcmcia driver currently in use can be unloaded.
> split_init: split the socket driver registration into two logical pieces.
> register: a new registration scheme is based upon struct pcmcia_socket and
> struct class_dev. [NOTE: SA11* drivers need to be converted]
In bk. sa11xx code updated and in bk as well.
> callback: use struct pcmcia_socket* as callback; and unify pci_socket.c and
> yenta.c. [NOTE 1: SA11* drivers need to be converted] [NOTE 2: only
> re-diffed, and due to the large size not re-sent to this list but only to
> rmk directly -- it's availably upon request, of course]
Looking at this one, we're preserving socket->sock, and we have the
equality socket === socket->sock. It looks like we have about 15 uses
of socket->sock which really want to be struct pcmcia_socket (calling
the socket drivers.) Rather than creating socket->socket_no in addition
to preserving socket->sock, wouldn't it be better to just convert those
15 places to use just "socket" ?
I realise that socket->socket_no will vanish in the tenth patch. However,
with this change, I think we'd get rid of both sock and socket_no.
Since they're both deprecated, I think this is a win.
Russell King (rmk at arm.linux.org.uk) The developer of ARM Linux
More information about the linux-pcmcia