[PATCH v3 2/2] acpi: Move check for _DSD StorageD3Enable property to acpi

Christoph Hellwig hch at lst.de
Sun May 30 23:53:04 PDT 2021


On Fri, May 28, 2021 at 11:02:53AM -0500, Mario Limonciello wrote:
> Although first implemented for NVME, this check may be usable by
> other drivers as well.

I think we want to expand this a little more, mentioning that the
Microsoft spec for it also explicitly mentions SATA/AHCI, that Google
has a local tree where this applied to SDHCI and that even if a slot
is intended for storage a user can plug any card into it.

> +/**
> + * acpi_storage_d3 - Check if a storage device should use D3.
> + * @dev: Device to check
> + *
> + * Look for a _DSD property specifying that the storage device
> + * should use D3 to support deep platform power savings during
> + * suspend-to-idle.
> + *
> + */

Maybe something like:

/**
 * acpi_storage_d3 - check if a device must use D3 for suspend
 * @dev: Device to check
 *
 * Returns %true if @pdev should be put into D3 when the ->suspend method is
 * called, else %false.  The name of this function is somewhat misleading
 * as it has nothing to do with storage except for the name of the ACPI
 * property.  On some platforms resume will not work if this hint is ignored.
 */



More information about the Linux-nvme mailing list