[PATCH v3 2/5] nvme-core: introduce complete failed request
Chao Leng
lengchao at huawei.com
Thu Jan 21 20:46:41 EST 2021
On 2021/1/21 16:41, Christoph Hellwig wrote:
>> +static inline void nvme_complete_failed_req(struct request *req)
>
> I think the name is too generic, and the function also needs a little
> comment, especially as it forces a specific error code.
Ok, thank you for your suggestion. Use error status as a parameter may
be a better choice.
>
>> +{
>> + nvme_req(req)->status = NVME_SC_HOST_PATH_ERROR;
>> + blk_mq_set_request_complete(req);
>> + nvme_complete_rq(req);
>> +}
>
> Also no need to mark this as an inline function.
Yes, export the function is ok.
> .
>
More information about the Linux-nvme
mailing list