[PATCH v3 2/5] nvme-core: introduce complete failed request

Christoph Hellwig hch at lst.de
Thu Jan 21 03:41:50 EST 2021


> +static inline void nvme_complete_failed_req(struct request *req)

I think the name is too generic, and the function also needs a little
comment, especially as it forces a specific error code.

> +{
> +	nvme_req(req)->status = NVME_SC_HOST_PATH_ERROR;
> +	blk_mq_set_request_complete(req);
> +	nvme_complete_rq(req);
> +}

Also no need to mark this as an inline function.



More information about the Linux-nvme mailing list