[PATCH rfc 5/6] nvme-pci: open-code polling logic in nvme_poll

Sagi Grimberg sagi at grimberg.me
Wed Oct 5 10:02:15 PDT 2016


>> Given that the code is simple enough it seems better
>> then passing a tag by reference for each call site.
>>
>> Signed-off-by: Sagi Grimberg <sagi at grimberg.me>
>> ---
>>  drivers/nvme/host/pci.c | 36 +++++++++++++++++++++---------------
>>  1 file changed, 21 insertions(+), 15 deletions(-)
>>
>
> I don't really see how the call by value vs. call by reference change is a
> better trade-off than open coding __nvme_process_cq(), as we'd have to
> duplicate any possible fix for this function then (yes I see it's quite
> simple but I have some doubt it's 100% bugfree).

I just figured it'd be nicer to remove the tag that we carry in all
the call sites because we want to reuse the code in nvme_poll(). It
made better sense before, but now that its simpler (for me at least)
we can lose it.

Having said that, we can easily remove this patch if we're not all
on board...



More information about the Linux-nvme mailing list