[GIT PULL] mtd: spi-nor: Changes for 5.18
Miquel Raynal
miquel.raynal at bootlin.com
Fri Mar 18 15:51:25 PDT 2022
Hello,
Tudor.Ambarus at microchip.com wrote on Tue, 8 Mar 2022 16:08:50 +0000:
> Hello,
>
> This is the SPI NOR PR for 5.18.
Pulled, thanks!
Miquèl
>
> Cheers,
> ta
>
> The following changes since commit cfb92440ee71adcc2105b0890bb01ac3cddb8507:
>
> Linux 5.17-rc5 (2022-02-20 13:07:20 -0800)
>
> are available in the Git repository at:
>
> git://git.kernel.org/pub/scm/linux/kernel/git/mtd/linux.git tags/spi-nor/for-5.18
>
> for you to fetch changes up to 151c6b49d679872d6fc0b50e0ad96303091694a2:
>
> mtd: spi-nor: Skip erase logic when SPI_NOR_NO_ERASE is set (2022-03-08 10:36:56 +0200)
>
> ----------------------------------------------------------------
> SPI NOR core changes:
> - move vendor specific code out of the core into vendor drivers.
> - unify all function and object names in the vendor modules.
> - make setup() callback optional to improve readability.
> - skip erase logic when the SPI_NOR_NO_ERASE flag is set at flash
> declaration.
>
> ----------------------------------------------------------------
> Michael Walle (32):
> mtd: spi-nor: atmel: unify function names
> mtd: spi-nor: catalyst: unify function names
> mtd: spi-nor: eon: unify function names
> mtd: spi-nor: esmt: unify function names
> mtd: spi-nor: everspin: unify function names
> mtd: spi-nor: fujitsu: unify function names
> mtd: spi-nor: gigadevice: unify function names
> mtd: spi-nor: intel: unify function names
> mtd: spi-nor: issi: unify function names
> mtd: spi-nor: macronix: unify function names
> mtd: spi-nor: micron-st: unify function names
> mtd: spi-nor: spansion: unify function names
> mtd: spi-nor: sst: unify function names
> mtd: spi-nor: winbond: unify function names
> mtd: spi-nor: xilinx: unify function names
> mtd: spi-nor: xmc: unify function names
> mtd: spi-nor: slightly refactor the spi_nor_setup()
> mtd: spi-nor: allow a flash to define its own ready() function
> mtd: spi-nor: export more functions to be used in vendor modules
> mtd: spi-nor: guard _page_size parameter in S3AN_INFO()
> mtd: spi-nor: move all xilinx specifics into xilinx.c
> mtd: spi-nor: xilinx: rename vendor specific functions and defines
> mtd: spi-nor: xilinx: correct the debug message
> mtd: spi-nor: move all micron-st specifics into micron-st.c
> mtd: spi-nor: micron-st: convert USE_FSR to a manufacturer flag
> mtd: spi-nor: micron-st: rename vendor specific functions and defines
> mtd: spi-nor: spansion: slightly rework control flow in late_init()
> mtd: spi-nor: move all spansion specifics into spansion.c
> mtd: spi-nor: spansion: convert USE_CLSR to a manufacturer flag
> mtd: spi-nor: spansion: rename vendor specific functions and defines
> mtd: spi-nor: slightly change code style in spi_nor_sr_ready()
> mtd: spi-nor: renumber flags
>
> Tudor Ambarus (1):
> mtd: spi-nor: Skip erase logic when SPI_NOR_NO_ERASE is set
>
> drivers/mtd/spi-nor/atmel.c | 81 +++++++++----------
> drivers/mtd/spi-nor/catalyst.c | 6 +-
> drivers/mtd/spi-nor/core.c | 268 +++++----------------------------------------------------------
> drivers/mtd/spi-nor/core.h | 70 +++++++----------
> drivers/mtd/spi-nor/eon.c | 6 +-
> drivers/mtd/spi-nor/esmt.c | 6 +-
> drivers/mtd/spi-nor/everspin.c | 6 +-
> drivers/mtd/spi-nor/fujitsu.c | 6 +-
> drivers/mtd/spi-nor/gigadevice.c | 6 +-
> drivers/mtd/spi-nor/intel.c | 6 +-
> drivers/mtd/spi-nor/issi.c | 10 +--
> drivers/mtd/spi-nor/macronix.c | 14 ++--
> drivers/mtd/spi-nor/micron-st.c | 259 ++++++++++++++++++++++++++++++++++++++++++++++++------------
> drivers/mtd/spi-nor/spansion.c | 168 +++++++++++++++++++++++++++++----------
> drivers/mtd/spi-nor/sst.c | 44 +++++------
> drivers/mtd/spi-nor/winbond.c | 29 +++----
> drivers/mtd/spi-nor/xilinx.c | 97 ++++++++++++++++++++---
> drivers/mtd/spi-nor/xmc.c | 6 +-
> include/linux/mtd/spi-nor.h | 18 -----
> 19 files changed, 581 insertions(+), 525 deletions(-)
More information about the linux-mtd
mailing list