[PATCH] mtd: pxa3xx_nand: cleanup wait_for_completion handling
Nicholas Mc Guire
der.herr at hofr.at
Mon Feb 9 07:01:45 PST 2015
On Mon, 09 Feb 2015, Ezequiel Garcia wrote:
> On 02/01/2015 01:55 PM, Nicholas Mc Guire wrote:
> > return type of wait_for_completion_timeout is unsigned long not int, this
> > patch uses the return value of wait_for_completion_timeout in the condition
> > directly rather than assigning it to an incorrect type variable.
> > The timeout declaration cleanup is just for readability
> > Signed-off-by: Nicholas Mc Guire <hofrat at osadl.org>
> > ---
> > The variable used for handling the return of wait_for_cmpletion_timeout
> > was int but should be unsigned long, where it was not in use for anything
> > else and the return value in case of completion (>0) is not used it was
> > removed and wait_for_completion_timeout() used directly in the if condition.
> > To make the timeout values a bit simpler to read and also handle all of
> > the corner cases correctly the declarations are moved to msecs_to_jiffies().
> Not sure why you decided to put this explanation outside of the commit log.
> It looks useful so I'd move it up.
simply because I was not sure about what should go into the log and what not
but this has been clarified by Dan Carpenter - should have it correct in
> > This patch was only compile tested for pxa3xx_defconfig
> > (implies CONFIG_MTD_NAND_PXA3xx=y)
> The change looks good, but I would like someone to test it on real hardware.
More information about the linux-mtd