[PATCH] mtd: pxa3xx_nand: cleanup wait_for_completion handling

Ezequiel Garcia ezequiel.garcia at free-electrons.com
Mon Feb 9 05:00:29 PST 2015

On 02/01/2015 01:55 PM, Nicholas Mc Guire wrote:
> return type of wait_for_completion_timeout is unsigned long not int, this
> patch uses the return value of wait_for_completion_timeout in the condition
> directly rather than assigning it to an incorrect type variable.
> The timeout declaration cleanup is just for readability
> Signed-off-by: Nicholas Mc Guire <hofrat at osadl.org>
> ---
> The variable used for handling the return of wait_for_cmpletion_timeout
> was int but should be unsigned long, where it was not in use for anything
> else and the return value in case of completion (>0) is not used it was
> removed and wait_for_completion_timeout() used directly in the if condition.
> To make the timeout values a bit simpler to read and also handle all of
> the corner cases correctly the declarations are moved to msecs_to_jiffies().

Not sure why you decided to put this explanation outside of the commit log.
It looks useful so I'd move it up.

> This patch was only compile tested for pxa3xx_defconfig 
> (implies CONFIG_MTD_NAND_PXA3xx=y)

The change looks good, but I would like someone to test it on real hardware.
Ezequiel García, Free Electrons
Embedded Linux, Kernel and Android Engineering

More information about the linux-mtd mailing list