[PATCH v3 3/6] mtd: set the ecc step size for master/slave mtd_info

Gupta, Pekon pekon at ti.com
Mon Aug 12 03:00:50 EDT 2013


> 
> Set the ecc step size for master/slave mtd_info{}.
> 
> Signed-off-by: Huang Shijie <b32955 at freescale.com>
> ---
>  drivers/mtd/mtdpart.c        |    1 +
>  drivers/mtd/nand/nand_base.c |    1 +
>  2 files changed, 2 insertions(+), 0 deletions(-)
> 
> diff --git a/drivers/mtd/mtdpart.c b/drivers/mtd/mtdpart.c
> index 3014933..63b42a6 100644
> --- a/drivers/mtd/mtdpart.c
> +++ b/drivers/mtd/mtdpart.c
> @@ -516,6 +516,7 @@ static struct mtd_part *allocate_partition(struct
> mtd_info *master,
>  	}
> 
>  	slave->mtd.ecclayout = master->ecclayout;
> +	slave->mtd.ecc_step = master->ecc_step;
>  	slave->mtd.ecc_strength = master->ecc_strength;
>  	slave->mtd.bitflip_threshold = master->bitflip_threshold;
> 
> diff --git a/drivers/mtd/nand/nand_base.c b/drivers/mtd/nand/nand_base.c
> index 8f04fb0..6e4095d 100644
> --- a/drivers/mtd/nand/nand_base.c
> +++ b/drivers/mtd/nand/nand_base.c
> @@ -3788,6 +3788,7 @@ int nand_scan_tail(struct mtd_info *mtd)
>  	/* propagate ecc info to mtd_info */
>  	mtd->ecclayout = chip->ecc.layout;
>  	mtd->ecc_strength = chip->ecc.strength;
> +	mtd->ecc_step = chip->ecc.size;

[Pekon]: Sorry for noticing this lately.. 
But do you really want to name ecc.*size* as *ecc_step* ?
Wouldn't it be better to follow same nomenclature everywhere ?
Like ' mtd->ecc_size = chip.ecc.size;'

Because we also have ecc.steps as another parameter here.
And someone might want to expose it in user-space later.
(Just a naming change requested here to keep things in sync..)

with regards, pekon

>  	/*
>  	 * Initialize bitflip_threshold to its default prior scan_bbt() call.
>  	 * scan_bbt() might invoke mtd_read(), thus bitflip_threshold must
> be
> --
> 1.7.1



More information about the linux-mtd mailing list