Internal error: Oops: 817 [#1]

E Robertson e.robertson.svg at
Thu Jul 30 17:22:19 EDT 2009

On Thu, Jul 30, 2009 at 3:29 PM, Daniel Mack<daniel at> wrote:
> On Thu, Jul 30, 2009 at 03:14:43PM -0500, E Robertson wrote:
>> I got 2.6.31-rc4 and patch it which wasn't painful.
>> However, no change.
>> Here are the results: My initramfs initially mount the two nand
>> partitions and that's where the initial
>> uncorrectable error comes from.
> Some thoughts.
> Could you try running the torture test from drivers/mtd/tests? Which
> platform is that? Are you sure you're running the NAND chip well inside
> its timing specs? Does the flash access work from the bootloader?
> I recently had similar trouble which disappeared after I switched off
> CPU frequency scaling.

I see these tests but I'm not sure how they're used. is their a doc for these?
I'm on a sam9263 platform and I'm sure my timing are within spec.
Infact I stretched
my to be sure it's not timing related. When it works I can see the
files from my bootloader.
Also when it doesn't work, I can still see file fragments.
I briefly tried creating and mounting a ubi volume which worked until
I repeated it with a file
loaded. I get some uncorrectable errors but since I'm not familiar
with this fs and never
used this filesystem before, this could very well be user error.

More information about the linux-mtd mailing list