goofy mtd m25p80 patches in GIT ...
G.Chen at freescale.com
Mon Oct 20 04:37:37 EDT 2008
> -----Original Message-----
> From: David Brownell [mailto:david-b at pacbell.net]
> Sent: 2008?10?20? 16:31
> To: Chen Gong-B11801
> Cc: David Woodhouse; linux-mtd at lists.infradead.org
> Subject: Re: goofy mtd m25p80 patches in GIT ...
> On Monday 20 October 2008, Chen Gong-B11801 wrote:
> > I prefer to the first opinion -- renaming 'erase_block' to
> > it looks more straightforward
> *AND* fixing the name of the operation.
> The pre-existing erase operations were:
> #define OPCODE_BE_4K 0x20 /* Erase 4KiB block */
> #define OPCODE_BE_32K 0x52 /* Erase 32KiB block */
> #define OPCODE_SE 0xd8 /* Sector erase
> (usually 64KiB) */
> So I'm quite puzzled why you would call the chip erase
> opcode a "block erase" opcode ... it's not a 4K block,
> not a 32K block, not a sector (of, usually, 64K).
ah, simple, because I'v gotten it from its datasheet (BE means Bulk
Erase, not block erase here) :-)
> It's more typically something like multiple MBytes.
> Having read or skimmed several dozen SPI flash specs,
> none of them called chip erase a "block erase" operation.
More information about the linux-mtd