I want to mount nandsim as vfat using nftl

Hyojeong Lee hj.lee.0215 at gmail.com
Sat Feb 16 04:23:20 EST 2008

I want to mount nandsim as vfat using nftl.
For the reason of my board, I should use linux
And in that version, nftl_format utility is not available.

I compiled MTD, nftl, nandsim and so on.
(nandsim is not tristate in the version of so I couldn't make it as
a module)

I can see
dev:        size     erasesize  name
mtd0:  00800000 0020000 "NAND simulator partition"
in /proc/mtd

and I can see /dev/mtdblock0

I want to make a situation as follows


I tried
mknod /dev/nftla b 93 0
mknod /dev/nftla1 b 93 1
fdisk /dev/nftla

but the kernel says that
"Unable to open /dev/nftla"

I tried insmod nftl.ko on every point I could try.
But same error occurs.

What I should do to achieve my goal?
Or where can I get information?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.infradead.org/pipermail/linux-mtd/attachments/20080216/e4998455/attachment.html 

More information about the linux-mtd mailing list