[JFFS2] check_node_data: MTD point returned len too short warnings

pan.kierownik at gazeta.pl pan.kierownik at gazeta.pl
Fri Mar 30 07:13:37 EDT 2007

Hi all,

I'm currently trying to use jffs2 on mtd device on our ARM926EJ-S
development board. We have here Intel Sibley 512Mb flash memory,
uClinux with kernel 2.6.19-uc1 and following problem:

    /> unlock /dev/mtd3
    /> eraseall /dev/mtd3
    Erasing 256 Kibyte @ fc0000 -- 98 % complete.
    /> mount -t jffs2 -o noatime /dev/mtdblock3 /mnt
    /> cp -r /bin /mnt
    /> sync
    /> umount /mnt
    /> mount -t jffs2 -o noatime /dev/mtdblock3 /mnt
    <4>JFFS2 warning: (176) check_node_data: MTD point returned len
too short: 1573 instead of 2577.
    <4>JFFS2 warning: (176) check_node_data: MTD point returned len
too short: 1998 instead of 2394.
    ... and so on - message repeated hundreds of time

After mounting file system I can run programs from that partition
without any problem.

I've tried to create jffs2 using mkfs.jffs2 (v1.43) on host:
    mkfs.jffs2 -p -rromfs -e262144 -offs.bin -c1024 -s1024
and then write directly to the flash where mtd3 partition is
located. The same warnings are displayed.

I tried to place jffs2 root file system in flash and start kernel
with following parameters:
    root=/dev/mtdblock3 rw rootfstype=jffs2 noinitrd init=/bin/init
console=ttyJ0 rootflags=noatime

When it comes to mount rootfs, the same check_node_data warnings
occurs and kernel panics. But for now, I just would like to get rid
of these warnings.

Best regards,

More information about the linux-mtd mailing list