Eraseblocks torture: OneNAND results

Kyungmin Park kyungmin.park at
Fri Dec 22 02:58:59 EST 2006

Hi Jarkko Lavinen

> I have tried your patch on an Omap 2420 base test board with OneNand
> and it seems to work.

Oh it's good news, In our environment. it's hard to produce the problem.
I erase it more than 1,000k (2 weeks). but it's still working.

> I had previously run an earlier version of torture test and had some
> worn out erase blocks available. When I try to erase them I see often
> controller error occuring and it is caught and returned correctly.

I commited the patch in OneNAND MTD git. and it will be merged into mtd.

> But I have also encounted cases where there is no erase error but yet
> erase verify fails. I then tried a retry aften the failed verify and 
> on the second read the erase block is blank, all FF, as it should.

As you know. If the block is worn-out. we don't sure its behavior.

Actually I don't have any idea. How can we handle this one?

Thank you,
Kyungmin Park

More information about the linux-mtd mailing list