mtd permission denied

Aras Vaichas arasv at
Tue Mar 22 01:43:11 EST 2005

Mike Lee wrote:
> Hi all
>   i tried to flash_erase and other flash_* tools to my mtd device, the
> return value is permission denied, but i am already root login. I have
> selected MTD_CHAR and MTD_BLOCK in kernel.  Do i miss somethings?
>     My kernel version is 2.6.10, with cvs mtd patched.
> Mike,Lee

This is spookey, I just got the exact same problem at the same time(!)

I'm trying to write data to my Dataflash device, but I get a "permission 
denied" error whenever I try to fopen the file "/dev/mtd/2" to write the data 
into it. I can read data from it with no problems.

I have tried "mtd_debug write" and "flashcp" and they return permission denied 
as well. Am I missing something?

I am using 2.4.27-vrs1 with cvs mtd patched.

/root # mtd_debug info /dev/mtd/2
mtd.type = MTD_NORFLASH
mtd.flags = MTD_ERASEABLE
mtd.size = 786432 (768K)
mtd.erasesize = 1056 (1K)
mtd.oobblock = 0
mtd.oobsize = 0
mtd.ecctype = MTD_ECC_NONE
regions = 0


Aras Vaichas

More information about the linux-mtd mailing list