SPI DataFlash interfacing using 2.4.27-vrs1

Narinder Kumar narinder at kritikalsolutions.com
Mon Mar 7 07:39:01 EST 2005

Dear Mr. Andrew,

               I tried out the solution that you mentioned in the last 
mail (please look into the mail below) but still i am not able to reach 
at a safe state. It did helped a bit in the sense that now my flash code 
recovers from CRC errors sometimes but sometimes it fails too and it 
fails because of Data corruption and when it fails it aborts my 
application and thereafter i have to start from the beginning i.e 
erasing the flash completely and then putting the application again.

Can you please guide me in a bit detailed manner ?
Which version of MTD is being used by you ?

I tried out  mtd-snapshot-20050217.tar and latest one also but still not 
able to get rid of my problem.
I installed mtd using patchin.sh script with "-c -j" options and i 
copied an older version(1.60) of mtdchar.c file as the newer one was 
giving errors during kernel compilation and when i replaced it with 
older version mtdchar then the kernel compiled succesfully.
If there is something crucial that i am missing out please let me know. 
I hope you have not done any major changes in the patches itself to get 
it working, if that is the case can you please update me where from can 
i get the working patches for 2.4.27-vrs1 or if you can forward the 
patches to me , that will be great.


Andrew Victor wrote:

>hi Narinder,
>>         Did anyone on the group sucessfully interfaced a JFFS2 
>>partition on SPI DataFlash on Atmel's AT91RM9200 DK using  kernel 2.4.26 
>>? I have been able to mount the partition but read/write was giving CRC 
>I'm running JFFS2-on-DataFlash successfully on 2.4.27-vrs1.
>1) You will need to download the latest CVS version of the MTD/JFFS2
>code from cvs.infradead.org (see http://www.linux-mtd.infradead.org/ for
>2) Read the INSTALL file and then run the ./patchin.sh script
>3) There are some incompatibilities with 2.4 kernels, but they're not
>difficult to fix.  This might help:
>4) Configure your kernel and enable "JFFS2 write-buffering support"
>under Filesystems->JFFS2.
>  Andrew Victor

More information about the linux-mtd mailing list