Cannot bulid grub_firmware for DOC2000

Stephan Wiebusch stephanwib at
Mon Dec 13 10:46:27 EST 2004

Hi all!

I am trying to build a grub bootloader-firmware for a Diskonchip-2000 (16MB)
Therefor, I used the howto found at

The DOC should be used in a small x86-PC-system. It is devided in only one
ext2-partition, where a 2.6.9-Kernel is located in /boot and a „menu.lst“
file in /boot/grub.
My development PC uses Fedora Linux Core 3.

I was able to build „grub_firmware“ in /stage1 directory only for one time;
but i cannot remember the combination of grub package and mtd-patch anymore.
After installing it on the DOC using M-System´s DOS-TOOLS, grub successfully
booted from it. But unfortunately grub says: „Error 23: Error while parsing
Using the DOC in my development PC, grub was able to recognize the
ext2-filesystem on my hard disk („root hd(0,0)“).

I tried to build the Grub sources from CVS with the mtd-grub-patch
2003-11-10 (not compiling) and 2003-01-08 (compiling, but no
grub_firmware).With these patches,  I also tried the grub-0.92 (also with
grub-0.92-patch) and grub-0.95 packages from the ftp-server, but all
combinations were not able to compile successfully.

I did it this way:

1)Patch grub with „patch –p0 –i ../mtd/patches/<patch-file>“
2)aclocal && autoconf –add-missing && automake
3)./configure –enable-diskonchip-2000 –enable-diskonchip-ctrlbypass
–enable-ext2fs –disable-ffs –disable-xfs –disable-jfs –disable-vstafs
–disable-reiserfs –disable-minix –disable-fat

Can anybody tell me a working combination or how to fix my problem? Or can I
use an alternative bootloader (unfortunately, i did not find any information
about using lilo)?
I also would be happy if anybody would send me his/her grub_firmware file.

Greetings, Stephan

More information about the linux-mtd mailing list