Trouble with mtd partition

Ccool ccool at
Fri Aug 27 02:10:53 EDT 2004


This trouble might look like a neebies, but I'm really having a hard time with 
this.  I installed a few options in my kernel so I could have an mtd 
character device.  I tried edit physmap.c and whenever I was never abler to 
get anything more than one big partition of my flash disk.

something like:
mtd0	01000000	00040000	"Physical map something"

I would really like it if I could have an mtd0, and also mtd1, mtd2, etc.  
like in my configuration file.  If anyone knows "a magic trick" or anything 
that could help me with that.  I cannot really work with only one big 
partition, because there is some data that I don't want to erase (bootloader) 
on the flash disk.  So if you could help me, I would appreciate it very much.

If it helps (because I surely don't understand what's happenning), it is like 
if the partition structure in the physmap.c was not taken count off.  I tried 
also to put some information into the init string, mtdparts=...  but even 
with all the examples that I found via google, I never had anything up and 
working.  If I could only have this structure working.  In attachement, there 
is my physmap.c (pretty much basic).  I've also tried with the rpxlite.c, 
because it is my board, and it did'nt work.  Actually, in rpxlite.c, I did'nt 
find any place to put my partitions structure.  My board is an RPXlite with 
16 meg of ram and 16 meg of Flash, they have mpc823e processor.  I have CW 
and DW version of this board.  As the memory map is a little different, I've 
only pu some example for the DW.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: physmap.c
Type: text/x-csrc
Size: 4244 bytes
Desc: not available
Url : 

More information about the linux-mtd mailing list