patches to 2.4.18

John Sutton john at
Tue May 7 14:10:28 EDT 2002

David Woodhouse dwmw2 at wrote:
> jim at said:
> >  Also, I (like so many others lately), had to comment out the call to
> > invalidate_device() in mtdblock.c::mtdblock_release() in order to get
> > my root filesystem (jffs2 on mtdblock on Intel Strataflash) to mount.
> > I note that the call is still there in the CVS vsion:
> Eep. That was removed from CVS long ago, but was added back again. I've
> now  removed it again.
> >  and we are getting crashes on halt/reboot if we've modified the
> > filesystem. 
> More details please.
> >  Similar questions about jffs2 have been asked:
> >
> > With no apparent answer.
> > anyone with clue to offer? 
> For the MTD drivers, the code in 2.4.19-pre is probably the best option 
> unless you need the new features I held back for 2.4.20-pre. For JFFS2,
> you  should be using the code from the jffs2-2_4-branch in CVS. I _think_
> that's  all been sent to Marcelo for 2.4.19 though. 

I'm a newbie with CVS... but the paragraph above makes it sound like there
are a number of different branches, and that the one I need is called
2.4.19-pre.  So I tried:

cvs -d:pserver:anoncvs at co -r 2.4.19-pre mtd

but got back:

cvs [server aborted]: Numeric tag 2.4.19-pre contains characters other than digits and '.'

So I tried:

cvs -d:pserver:anoncvs at co -r 2.4.19 mtd

and that seemed to work i.e. it said the right things about "Updating mtd"
etc but actually it downloaded nothing ;-(

Help much appreciated!

John Sutton
SCL Internet
Tel. +44 (0) 1239 711 888

More information about the linux-mtd mailing list