lilo and mtd ans doc

Vipin Malik vipin.malik at
Tue Sep 4 12:14:16 EDT 2001

Patrick Allaire wrote:

> I have tried what you have told me but it does not seem to change a thing
> !!! The systems is still hanging on "Kernel panic : VFS: Unable to mount
> root fs on 03:05" !!!!!!!!!
> Where does it find the information to search 03:05 to boot ? I did compile
> the kernel on /dev/hda5 !!! Is there a place in the kernel config where I
> could specify the boot device ? Is this information stored in boot.b-mtd (I
> dont think so) ? In the /boot/map ??? the last one is generated by lilo ? no
> ? so it should not contain /dev/hda5 information since I run lilo-mtd from a
> floppy the HD was removed !
> I have added those two lines to my lilo.conf :
> prompt
> timeout=50
> Then I have tried what you told me. When I boot ... I write :
> lilo: s append="root=/dev/nftla1"

This may be a valid way to specify lilo cmd's too, but I would do just:

LILO: s root=/dev/nftla1

and try that.

You need the append="...." only when you specify the cmd line args in the
lilo.conf file, not if you are specifing them during boot time.



More information about the linux-mtd mailing list