erase and 2.4.4 kernel

Williams, Kevin M. kevin.m.williams at
Fri May 4 11:30:06 EDT 2001

I upgraded my kernel from 2.4.3-pre3 to the 2.4.4 release.  I also copied
over the mtd snapshot from 25 April.  Now when I try the erase command, I

bash#> /sbin/erase /dev/mtd2 0 6
Erase Total 6 Units
Invalid ioctl 80044d07 (MEMGETINFO = 40204d01)

This was working fine when I load my 2.4.3 kernel with the 4 April mtd
snapshot patched in.  

Any advice?


-----Original Message-----
From: David Woodhouse [mailto:dwmw2 at]
Sent: Thursday, May 03, 2001 5:55 PM
To: Jeff Smith
Cc: linux-mtd at
Subject: Re: JFFS2 Problem 

jsmith at said:
>  I'm running jffs2 on a PPC/855T board. I mount the jffs2 and have two
> (2) test scripts that "dd" various sized files to the jffs2 flash. I
> seem to be running into a race condition or something.

> My 2 scripts just "dd" a bunch of files to the jffs2/flash, "ls -l "
> them, "rm *" them and then "ls -l" the dir/mnt point again in a loop.
> I'm running 2 of these and they always reach contention fairly
> quickly, ie. they lock up after 5 to 10 iterations. ps shows the
> processes sleeping. If I remove the "ls"portion of the scripts. That
> is I just "dd" and "rm" - everything "seems" ok.Anybody seen this? 

Sorry for the delayed response.

I've seen similar, and I thought I'd fixed it. You may have found a code 
path which I hadn't considered, and which still has locking problems. Or 
you may just be using the code from before I fixed it :)

What's the output of 'grep Id: fs/jffs2/*.[ch]'?

If it's still happening with the latest code, can you make sure you have 
SysRq enabled in your kernel and show me the backtraces of the offending 
processes? (SysRq-T and ksymoops for decoding)


Linux MTD discussion mailing list

More information about the linux-mtd mailing list