Instructions for booting from DOC-2000 chip?

Ralph Jennings ralph at
Mon Mar 5 21:46:39 EST 2001

I've looked all over, and from what I can gather, you need to update
your chip from DOS with "dformat.exe /win:d000 /s:doc2.fff /y" (or the
linux equivalent).

I've done that, but I still can't get it to boot, in fact now I don't
even get the "dLI" that I used to.  Though I can mount it and read
and write it from Linux 2.4.2 (using your drivers I'm guessing).

The lilo I got from M-Sys but changed the patch to work with your
major number instead of the M-Sys one.

Do I just need an updated doc2.fff file?  If so, where do I get it?
I got mine from dos utilities version 4.2 and Linux
drivers version 4.2.1 (they would let me read and write too, but no
luck booting with these drivers either).

Any help?  If I need to use grub, fine. (I'd prefer LiLo though)  I
just need it to boot Linux (with only 1 full size ext2 partition).

I have 2 machines:
    Advantech PCM-4823
    Advantech PCM-4823L

I have 2 chips:
    DOC-2000 16MB
    What looks like a DOC-2000 8MB, but your drivers say Milenium.

I haven't yet tried anything with the 16MB chip, because I've
gotten nowhere on the 8MB (the first one I picked up, and tried
getting to work).

Thanks, Ralph.

To unsubscribe, send "unsubscribe mtd" to majordomo at

To unsubscribe, send "unsubscribe mtd" to majordomo at

To unsubscribe, send "unsubscribe mtd" to majordomo at

More information about the linux-mtd mailing list