Problems compiling kernel 2.2.1-rmk2

Alex Liao alex at
Tue Aug 7 07:34:03 EDT 2001

Hi all,
        I have problems about compiling MTD with kernel 2.2.1-rmk2(patched
arm-patch files).
        I used AMD flash chip (support CFI ) .
        Error message:
        cfi_cmdset_0002.c: In function 'do_read_onechip':
        cfi_cmdset_0002.c:206: dereferencing pointer to incomplete type
        cfi_cmdset_0002.c:208: dereferencing pointer to incomplete type
        cfi_cmdset_0002.c:209: dereferencing pointer to incomplete type

                    ....... so many error msg like above.......
        Could anyone give me help or suggestions to resolve the problems ?


----- Original Message -----
From: "David Woodhouse" <dwmw2 at>
To: "Juan Ramon Jimenez Garcia" <juan at>
Cc: <linux-mtd at>; <olea at>
Sent: Tuesday, August 07, 2001 5:48 PM
Subject: Re: Problems compiling kernel 2.2.17

> juan at said:
> >  but now we got another link error with an undefined reference to
> > 'init_nftl'
> init_nftl was declared 'static' because that works in 2.4 and I don't
> test with 2.2 kernels before 2.2.18 (where it also works because the 2.4
> initcall stuff has been merged). I've now fixed it in v1.77 of nftlcore.c.
> > How can we solved this? Do you think we must to configure
> > something special to get the kernel image?
> Using 2.2.18 would help - it does the initcall stuff in the new way.
> Otherwise, it ought to work, it's mostly just details like the above which
> won't have noticed.
> --
> dwmw2
> ______________________________________________________
> Linux MTD discussion mailing list

More information about the linux-mtd mailing list