Naming of functions in 'mtdcore.c'

David Woodhouse dwmw2 at
Tue Sep 5 09:48:48 EDT 2000

sjhill at said:
> For the 'register_mtd_user' and 'unregister_mtd_user' functions would
> renaming them to something like 'add_mtd_notify_callbacks' and
> 'del_mtd_notify_callbacks' be more understandable? At a first read it
> would to me. Comments? 

You may be right. I already changed it from {un,}register_mtd_notifier
to what it is at the moment because I thought it made it clearer. But I'm 
not really the right person to judge. 

Now it's in 2.4 like that, though, it may be best to leave it as-is.


To unsubscribe, send "unsubscribe mtd" to majordomo at

More information about the linux-mtd mailing list